Merge "4a: Use '4a-hal-generic' gerrit repository"
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / recipes-multimedia / 4a-hal-generic / 4a-hal-generic_git.bb
index 0bff58a..264ba95 100644 (file)
@@ -1,14 +1,13 @@
 SUMMARY     = "4A - Generic HAL"
 DESCRIPTION = "Generic HAL in 4A (AGL Advanced Audio Agent)"
-HOMEPAGE    = "https://github.com/iotbzh/4a-hal-generic/"
+HOMEPAGE    = "https://git.automotivelinux.org/src/4a-hal-generic/"
 SECTION     = "apps"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-SRC_URI = "gitsm://github.com/iotbzh/4a-hal-generic;protocol=https;branch=${AGL_BRANCH}"
-#SRCREV = "${AGL_APP_REVISION}"
-SRCREV = "90cae7bdb9487225d11e8daeea0202a1db5605bb"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/src/4a-hal-generic;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "e2c70866cc7d4a55409fd459b02118c629b4b216"
 
 DEPENDS += "lua"
 
@@ -31,21 +30,25 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 # for specific machines, activate only known HALs
 4A_HAL_LIST_m3ulcb          ?= "rcar-m3 rcar-m3kf"
 4A_HAL_LIST_h3ulcb          ?= "rcar-m3 rcar-m3kf"
-4A_HAL_LIST_intel-corei7-64 ?= "intel-minnow"
+4A_HAL_LIST_intel-corei7-64 ?= "intel-minnow intel-upsquared-hdmi"
 4A_HAL_LIST_qemux86-64      ?= "intel-qemu"
+
+# Due to bug SPEC-1610, default hal for RPI3 is not active yet
+# 4A_HAL_LIST_raspberrypi3    ?= "raspberry-pi-3"
+
 ### TODO: this list should be completed for more machines
 
 do_install_append () {
-       # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
-       PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
-
-       # move all config files to a 'available' dir
-       mv $PKGDIR/etc $PKGDIR/etc.available
-
-       # then install only required hals files in the etc folder
-       mkdir -p $PKGDIR/etc
-       for x in ${4A_HAL_LIST}; do
-               hal=hal-4a-$x.json
-               mv -v $PKGDIR/etc.available/${hal}.json $PKGDIR/etc/
-       done
+    # get pkgdir - note that '4a-hal' comes from project ${project_git_repo}/conf.d/cmake/config.cmake
+    PKGDIR=${D}/${INSTALL_PREFIX}/4a-hal
+
+    # move all config files to a 'available' dir
+    mv $PKGDIR/etc $PKGDIR/etc.available
+
+    # then install only required hals files in the etc folder
+    mkdir -p $PKGDIR/etc
+    for x in ${4A_HAL_LIST}; do
+        hal=hal-4a-$x.json
+        mv -v $PKGDIR/etc.available/${hal} $PKGDIR/etc/
+    done
 }