bluez-alsa: updated patches due to latest bump
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / recipes-connectivity / bluez-alsa / bluez-alsa_git.bbappend
index ecb73b3..70c731a 100644 (file)
@@ -1,12 +1,18 @@
-# THIS IS A TEMPORARY WORKAROUND TO IMPLEMENT PERSISTENT PCMS FOR SOFTMIXER
+# This brings some mandatory patches for the softmixer and hal-manager.
+#
+# - patch 1 makes a communication library for hal-manager to get
+#   the list of audio transports from bluez-alsa
+# - patch 2 makes the "debug" macro always display the caller name
+# - patch 3 asks dbus for a name like 'org.bluez-alsa.hciX' where hciX 
+#   name of the HCI interface that the bluealsa daemon instance is handling
+# 
+# Notice that patch 2 will very likely be replaced by a full dbus interface
+# in the future.
+#
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-SRC_URI += "file://0001-Added-a-connection-proxy-plugin.patch"
-SRC_URI += "file://0002-proxy-plugin-close-transport-when-null-device-is-set.patch"
-
-FILES_${PN} += "\
-  ${libdir}/alsa-lib/libasound_module_pcm_bluealsa_proxy.so\
-  ${datadir}/alsa/alsa.conf.d/20-bluealsa_proxy.conf\
-"
+SRC_URI += "file://0001-build-and-link-with-a-shared-library.patch"
+SRC_URI += "file://0002-log-add-calling-function-name.patch"
+SRC_URI += "file://0003-dbus-request-a-name-on-startup.patch"