bluez-alsa: updated patches due to latest bump
[AGL/meta-agl-devel.git] / meta-audio-4a-framework / recipes-connectivity / bluez-alsa / bluez-alsa_git.bbappend
index 8c67037..70c731a 100644 (file)
@@ -1,10 +1,18 @@
-# This brings some mandatory patches for the softmixer. This is not an actual hack,
-# because all the 3 patches below have been discussed with the maintainer of bluez-alsa,
-# and will be mainlined in the future
+# This brings some mandatory patches for the softmixer and hal-manager.
+#
+# - patch 1 makes a communication library for hal-manager to get
+#   the list of audio transports from bluez-alsa
+# - patch 2 makes the "debug" macro always display the caller name
+# - patch 3 asks dbus for a name like 'org.bluez-alsa.hciX' where hciX 
+#   name of the HCI interface that the bluealsa daemon instance is handling
+# 
+# Notice that patch 2 will very likely be replaced by a full dbus interface
+# in the future.
+#
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 SRC_URI += "file://0001-build-and-link-with-a-shared-library.patch"
 SRC_URI += "file://0002-log-add-calling-function-name.patch"
-SRC_URI += "file://0003-increased-the-number-of-connexions-to-16.patch"
-SRC_URI += "file://0004-Fixed-the-SIGSEGV-at-PCM-close.patch"
+SRC_URI += "file://0003-dbus-request-a-name-on-startup.patch"
+