cynara: Fix build error that causes gcc v7.0
[AGL/meta-agl.git] / meta-app-framework / recipes-security / cynara / cynara_git.bbappend
index 9a61e70..4c38da1 100644 (file)
@@ -1,3 +1,8 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+SRC_URI_append = " file://0001-gcc-7-requires-include-functional-for-std-function.patch"
+
+CXXFLAGS_append = " -Wimplicit-fallthrough=0"
+
 pkg_postinst_${PN} () {
    # Fail on error.
    set -e