SPEC-3723: restructure meta-agl
[AGL/meta-agl.git] / meta-app-framework / recipes-platform / packagegroups / packagegroup-agl-app-framework.bb
diff --git a/meta-app-framework/recipes-platform/packagegroups/packagegroup-agl-app-framework.bb b/meta-app-framework/recipes-platform/packagegroups/packagegroup-agl-app-framework.bb
new file mode 100644 (file)
index 0000000..d15607a
--- /dev/null
@@ -0,0 +1,19 @@
+SUMMARY = "AGL Application Framework core packages"
+DESCRIPTION = "The set of packages required by the AGL Application Framework"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES_${PN} = "\
+    packagegroup-agl-app-framework \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} = "\
+       af-binder \
+       libafbwsc \
+       af-main \
+       nss-localuser \
+       af-platform-setup \
+       "