web-runtime: add missing runtime dependencies
[AGL/meta-agl.git] / meta-app-framework / recipes-core / web-runtime / web-runtime_0.1.bb
index fa14987..c58daea 100644 (file)
@@ -12,7 +12,16 @@ SRC_URI = "\
        file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
 "
 
-RDEPENDS_${PN} = "qtwebkit-qmlplugins"
+RDEPENDS_${PN} = "\
+  qtdeclarative-tools \
+  qtwebkit-qmlplugins \
+  qtwayland-qmlplugins \
+  qtquickcontrols-qmlplugins \
+"
+
+PROVIDES += "virtual/webruntime"
+# add also RPROVIDES to satisfy the packagegroup
+RPROVIDES_${PN} += "virtual/webruntime"
 
 do_configure() {
     :