Removing qtwebkit to be replaced by qtwebengine
[AGL/meta-agl.git] / meta-app-framework / recipes-core / web-runtime / web-runtime_0.1.bb
index 9df4dff..8cbe08a 100644 (file)
@@ -7,12 +7,20 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
 SRC_URI = "\
-       file://web-runtime;md5sum=00cdb6980e03cf8c8f7d60dd978c61d7 \
+       file://web-runtime;md5sum=6114c0bdd20290912a423fa01beb50f0 \
        file://web-runtime.qml;md5sum=5d6a379e9b7e5654319e5ba638824a58 \
        file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
 "
 
-RDEPENDS_${PN} = "qtwebkit-qmlplugins"
+RDEPENDS_${PN} = "\
+  qtdeclarative-tools \
+  qtwayland-qmlplugins \
+  qtquickcontrols-qmlplugins \
+"
+
+PROVIDES += "virtual/webruntime"
+# add also RPROVIDES to satisfy the packagegroup
+RPROVIDES_${PN} += "virtual/webruntime"
 
 do_configure() {
     :