Convert to new override syntax
[AGL/meta-agl.git] / meta-app-framework / recipes-core / nss-localuser / nss-localuser_0.1.bb
index 148bc51..93d2a20 100644 (file)
@@ -10,9 +10,11 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=79ad77111c398994735201536a4749ba"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/nss-localuser;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "d2d9e83bd9bdc3a091d6b9f1ccaec012fba2f0f4"
+SRCREV = "66803c6fdb609ed83a78b9194ecb23e9c1b773e7"
 PV = "${AGL_BRANCH}+git${SRCPV}"
 
+RDEPENDS:${PN} = "base-files"
+
 S = "${WORKDIR}/git"
 
 do_compile() {
@@ -23,15 +25,15 @@ do_install() {
        make nssdir=${D}${libdir} install
 }
 
-pkg_postinst_${PN} () {
+pkg_postinst_ontarget:${PN} () {
        sed -e '/^hosts:/s/\<localuser\>\s*//' \
                -e 's/\(^hosts:\s\s*\)\(.*\)/\1localuser \2/' \
                -i $D${sysconfdir}/nsswitch.conf
 }
 
-pkg_prerm_${PN} () {
+pkg_prerm:${PN} () {
        sed -e '/^hosts:/s/\<localuser\>\s*//' \
                -i $D${sysconfdir}/nsswitch.conf
 }
 
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"