Enforce separation of users using UMASK
[AGL/meta-agl.git] / meta-app-framework / recipes-core / base-files / base-files_%.bbappend
index 249f321..1dddcd6 100644 (file)
@@ -1,16 +1,18 @@
-RDEPENDS_${PN}_append_with-lsm-smack = " smack-userspace"
-PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-userspace-native"
+RDEPENDS_${PN}_append_with-lsm-smack = " smack"
+PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-native"
 
 do_install_append() {
-    install -d ${D}/${sysconfdir}/skel/app-data
-    install -d ${D}/${sysconfdir}/skel/.config
+    install -m 0700 -d ${D}/${sysconfdir}/skel
+    chmod -R 0700 ${D}/${sysconfdir}/skel
+    install -m 0700 -d ${D}/${sysconfdir}/skel/app-data
+    install -m 0700 -d ${D}/${sysconfdir}/skel/.config
     install -m 0755 -d ${D}/var
     if [ -d ${D}/usr/local ]; then
         mv ${D}/usr/local ${D}/var
     else
         install -m 0755 -d ${D}/var/local
     fi
-    ln -s ../../var/local ${D}/usr/local
+    ln -s ../var/local ${D}/usr/local
 }
 
 do_install_append_with-lsm-smack () {