libsdl2: PACKAGECONFIG tweaks
[AGL/meta-agl.git] / meta-app-framework / recipes-core / applaunchd / applaunchd_git.bb
index 5c2036a..d717141 100644 (file)
@@ -8,6 +8,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 DEPENDS = " \
     glib-2.0 \
     glib-2.0-native \
+    protobuf-native \
+    grpc-native \
+    grpc \
     systemd \
 "
 
@@ -15,30 +18,52 @@ PV = "2.0+git${SRCPV}"
 
 SRC_URI = " \
     git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
+    file://applaunchd.service \
     file://agl-app@.service \
+    file://agl-app-web@.service \
+    file://agl-app-flutter@.service \
     file://no-network.conf \
     file://private-tmp.conf \
 "
-SRCREV = "efbd734aca8b813710d7564d79696b1cf150a88c"
+SRCREV = "c52afaf8b5c96136fe20e5d5a1332121d3b09ee9"
 
 S = "${WORKDIR}/git"
 
-inherit meson pkgconfig
+inherit meson pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "applaunchd.service"
 
 do_install:append() {
     # Install generic template for all agl-app services
-    mkdir -p ${D}${sysconfdir}/systemd/system/
-    install -m 644 ${WORKDIR}/agl-app@.service ${D}${sysconfdir}/systemd/system/
+    install -d ${D}${systemd_system_unitdir}
+    install -m 644 ${WORKDIR}/applaunchd.service ${D}${systemd_system_unitdir}/
+    install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
+    install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
+    install -m 644 ${WORKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/
 
     # Install individual sandboxing overrides/drop-ins to be used by apps
-    mkdir -p ${D}${sysconfdir}/systemd/sandboxing/
-    install -m 644 ${WORKDIR}/no-network.conf ${D}${sysconfdir}/systemd/sandboxing/
-    install -m 644 ${WORKDIR}/private-tmp.conf ${D}${sysconfdir}/systemd/sandboxing/
+    install -d ${D}${systemd_system_unitdir}/sandboxing
+    install -m 644 ${WORKDIR}/no-network.conf ${D}${systemd_system_unitdir}/sandboxing/
+    install -m 644 ${WORKDIR}/private-tmp.conf ${D}${systemd_system_unitdir}/sandboxing/
 }
 
-FILES:${PN} += " ${datadir}/dbus-1/"
+PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web ${PN}-template-agl-app-flutter"
+
+FILES:${PN} += "${systemd_system_unitdir} ${datadir}/dbus-1/"
+
+FILES:${PN}-template-agl-app = "${systemd_system_unitdir}/agl-app@.service"
+
+FILES:${PN}-template-agl-app-web = "${systemd_system_unitdir}/agl-app-web@.service"
+
+FILES:${PN}-template-agl-app-flutter = "${systemd_system_unitdir}/agl-app-flutter@.service"
 
 RDEPENDS:${PN} += " \
     agl-session \
     polkit-rule-agl-app \
 "
+
+RDEPENDS:${PN}-template-agl-app = "${PN}"
+
+RDEPENDS:${PN}-template-agl-app-web = "${PN}"
+
+RDEPENDS:${PN}-template-agl-app-flutter = "${PN}"