meta-app-framework: applaunchd: update for gRPC addition
[AGL/meta-agl.git] / meta-app-framework / recipes-core / applaunchd / applaunchd_git.bb
index e6439c3..958f50b 100644 (file)
@@ -8,6 +8,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 DEPENDS = " \
     glib-2.0 \
     glib-2.0-native \
+    protobuf-native \
+    grpc-native \
+    grpc \
     systemd \
 "
 
@@ -15,21 +18,25 @@ PV = "2.0+git${SRCPV}"
 
 SRC_URI = " \
     git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
+    file://applaunchd.service \
     file://agl-app@.service \
     file://agl-app-web@.service \
     file://agl-app-flutter@.service \
     file://no-network.conf \
     file://private-tmp.conf \
 "
-SRCREV = "c675bafdf15cc19276bd8276c34f56404a5ecb62"
+SRCREV = "992f87151ff189dc061624f010eddee2036fd33f"
 
 S = "${WORKDIR}/git"
 
-inherit meson pkgconfig
+inherit meson pkgconfig systemd
+
+SYSTEMD_SERVICE:${PN} = "applaunchd.service"
 
 do_install:append() {
     # Install generic template for all agl-app services
     install -d ${D}${systemd_system_unitdir}
+    install -m 644 ${WORKDIR}/applaunchd.service ${D}${systemd_system_unitdir}/
     install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
     install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
     install -m 644 ${WORKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/