af-main & af-binder: Set version from AGLVERSION
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / nativesdk-af-main_git.bb
diff --git a/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb b/meta-app-framework/recipes-core/af-main/nativesdk-af-main_git.bb
new file mode 100644 (file)
index 0000000..759c893
--- /dev/null
@@ -0,0 +1,27 @@
+require af-main_${PV}.inc 
+
+inherit nativesdk cmake pkgconfig 
+
+SECTION = "base"
+
+DEPENDS = "nativesdk-openssl nativesdk-libxml2 nativesdk-xmlsec1 nativesdk-libzip nativesdk-json-c"
+
+EXTRA_OECMAKE = "\
+       -DUSE_LIBZIP=1 \
+       -DUSE_SIMULATION=1 \
+       -DUSE_SDK=1 \
+       -DAGLVERSION=${AGLVERSION} \
+       -Dafm_name=${afm_name} \
+       -Dafm_confdir=${afm_confdir} \
+       -Dafm_datadir=${afm_datadir} \
+"
+
+do_install_append() {
+    # remove unused .pc file we don't want to package
+       rm -rf ${D}/${libdir}
+}
+
+PACKAGES = "${PN}-tools ${PN}-tools-dbg"
+FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
+FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
+