afw: Fix error report
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / nativesdk-af-main_1.0.bb
index 426e999..8d04434 100644 (file)
@@ -4,11 +4,7 @@ inherit nativesdk cmake pkgconfig
 
 SECTION = "base"
 
-DEPENDS = "nativesdk-openssl nativesdk-libxml2 nativesdk-xmlsec1 nativesdk-libzip"
-
-afm_name    = "afm"
-afm_confdir = "${sysconfdir}/${afm_name}"
-afm_datadir = "${datadir}/${afm_name}"
+DEPENDS = "nativesdk-openssl nativesdk-libxml2 nativesdk-xmlsec1 nativesdk-libzip nativesdk-json-c"
 
 EXTRA_OECMAKE = "\
        -DUSE_LIBZIP=1 \
@@ -19,6 +15,11 @@ EXTRA_OECMAKE = "\
        -Dafm_datadir=${afm_datadir} \
 "
 
+do_install_append() {
+    # remove unused .pc file we don't want to package
+       rm -rf ${D}/${libdir}
+}
+
 PACKAGES = "${PN}-tools ${PN}-tools-dbg"
 FILES_${PN}-tools = "${bindir}/wgtpkg-* ${afm_confdir}/*"
 FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"