af-main: add RDEPENDS on bash
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / af-main_1.0.bb
index 5cc5740..7863874 100644 (file)
@@ -45,7 +45,7 @@ SYSTEMD_AUTO_ENABLE = "enable"
 FILES_${PN} += "\
        ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/afm-user-daemon.service', '', d)} \
 "
-RDEPENDS_${PN}_append_smack = " smack-userspace"
+RDEPENDS_${PN}_append_smack = " smack-userspace bash"
 DEPENDS_append_smack = " smack-userspace-native"
 
 # short hacks here
@@ -64,6 +64,8 @@ do_install_append_class-target() {
     install -d -m 0775 ${D}${systemd_units_root}/user
     install -d -m 0775 ${D}${systemd_units_root}/system/default.target.wants
     install -d -m 0775 ${D}${systemd_units_root}/user/default.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/system/sockets.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/user/sockets.target.wants
     install -d ${D}${afm_datadir}/applications
     install -d ${D}${afm_datadir}/icons
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
@@ -82,7 +84,7 @@ do_install_append_porter() {
 pkg_postinst_${PN}() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         for SYS in "system" "user";do
-           for DEST in "default.target.wants" ".";do
+           for DEST in "sockets.target.wants" "default.target.wants" ".";do
               chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
            done
         done
@@ -96,7 +98,7 @@ pkg_postinst_${PN}() {
 pkg_postinst_${PN}_smack() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         for SYS in "system" "user";do
-           for DEST in "default.target.wants" ".";do
+           for DEST in "sockets.target.wants" "default.target.wants" ".";do
               chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
               chsmack -a 'System::Shared' -t $D${systemd_units_root}/${SYS}/${DEST};
            done