tests: enable HW test for QEMU x86-64
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / af-main_1.0.bb
index 3c1b692..7863874 100644 (file)
@@ -45,7 +45,7 @@ SYSTEMD_AUTO_ENABLE = "enable"
 FILES_${PN} += "\
        ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/afm-user-daemon.service', '', d)} \
 "
-RDEPENDS_${PN}_append_smack = " smack-userspace"
+RDEPENDS_${PN}_append_smack = " smack-userspace bash"
 DEPENDS_append_smack = " smack-userspace-native"
 
 # short hacks here
@@ -56,43 +56,59 @@ SRC_URI += "\
 # tools used to install wgt at first boot
 SRC_URI += "\
        file://afm-install \
-       file://add-qt-wayland-shell-integration.patch \
 "
 
-do_install_append() {
+do_install_append_class-target() {
     install -d ${D}${bindir}
-    install -d -m 0775 ${D}${systemd_units_root}/{system,user}
-    install -d -m 0775 ${D}${systemd_units_root}/{system,user}/default.target.wants
-    install -d ${D}${afm_datadir}/{applications,icons}
+    install -d -m 0775 ${D}${systemd_units_root}/system
+    install -d -m 0775 ${D}${systemd_units_root}/user
+    install -d -m 0775 ${D}${systemd_units_root}/system/default.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/user/default.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/system/sockets.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/user/sockets.target.wants
+    install -d ${D}${afm_datadir}/applications
+    install -d ${D}${afm_datadir}/icons
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        mkdir -p ${D}${sysconfdir}/systemd/{system,user}/default.target.wants
+        mkdir -p ${D}${sysconfdir}/systemd/system/default.target.wants
+        mkdir -p ${D}${sysconfdir}/systemd/user/default.target.wants
         ln -sf ${systemd_user_unitdir}/afm-user-daemon.service ${D}${sysconfdir}/systemd/user/default.target.wants
     fi
     install -m 0755 ${WORKDIR}/afm-install ${D}${bindir}
+    echo "QT_WAYLAND_SHELL_INTEGRATION=ivi-shell" > ${D}${afm_confdir}/unit.env.d/qt-for-ivi-shell
 }
 
-do_install_append_qemux86-64() {
-    sed -i -e '/LD_PRELOAD=\/usr\/lib\/libEGL.so/d' ${D}${systemd_user_unitdir}/afm-user-daemon.service
+do_install_append_porter() {
+    echo "LD_PRELOAD=/usr/lib/libEGL.so" > ${D}${afm_confdir}/unit.env.d/preload-libEGL
 }
 
 pkg_postinst_${PN}() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        chgrp ${afm_name} $D${systemd_units_root}/{system,user}/{default.target.wants,.}
+        for SYS in "system" "user";do
+           for DEST in "sockets.target.wants" "default.target.wants" ".";do
+              chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
+           done
+        done
     fi
-    chown ${afm_name}:${afm_name} $D${afm_datadir}/{applications,icons,.}
+    for DEST in "applications" "icons" ".";do
+        chown ${afm_name}:${afm_name} $D${afm_datadir}/${DEST};
+    done
     setcap cap_mac_override,cap_dac_override=ep $D${bindir}/afm-system-daemon
-    setcap cap_mac_override,cap_mac_admin,cap_setgid=ep $D${bindir}/afm-user-daemon
 }
 
 pkg_postinst_${PN}_smack() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-        chgrp ${afm_name} $D${systemd_units_root}/{system,user}/{default.target.wants,.}
-        chsmack -a 'System::Shared' -t $D${systemd_units_root}/{system,user}/{default.target.wants,.}
+        for SYS in "system" "user";do
+           for DEST in "sockets.target.wants" "default.target.wants" ".";do
+              chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
+              chsmack -a 'System::Shared' -t $D${systemd_units_root}/${SYS}/${DEST};
+           done
+        done
     fi
-    chown ${afm_name}:${afm_name} $D${afm_datadir}/{applications,icons,.}
-    chsmack -a 'System::Shared' -t $D${afm_datadir}/{applications,icons,.}
+    for DEST in "applications" "icons" ".";do
+        chown ${afm_name}:${afm_name} $D${afm_datadir}/${DEST};
+        chsmack -a 'System::Shared' -t $D${afm_datadir}/${DEST};
+    done
     setcap cap_mac_override,cap_dac_override=ep $D${bindir}/afm-system-daemon
-    setcap cap_mac_override,cap_mac_admin,cap_setgid=ep $D${bindir}/afm-user-daemon
 }
 FILES_${PN} += " ${systemd_units_root} "
 
@@ -103,4 +119,3 @@ FILES_${PN}-binding-dbg = " ${afb_binding_dir}/.debug/afm-main-binding.so "
 PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
 FILES_${PN}-tools = "${bindir}/wgtpkg-*"
 FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
-