af-main: add RDEPENDS on bash
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / af-main_1.0.bb
index a29b071..7863874 100644 (file)
@@ -1,3 +1,5 @@
+require af-main_${PV}.inc 
+
 # NOTE: using libcap-native and setcap in install doesn't work
 # NOTE: there is no SYSTEMD_USER_SERVICE_...
 # NOTE: maybe setting afm_name to agl-framework is cleaner but has implications
@@ -5,42 +7,30 @@
 # NOTE: using ZIP programs creates directories with mode 777 (very bad)
 
 inherit cmake pkgconfig useradd systemd
-
-SUMMARY = "AGL Framework Main part"
-DESCRIPTION = "\
-This is a core framework component for managing \
-applications, widgets, and components. \
-"
-
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-main"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=1.0"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
-           ${SRC_URI_files} \
-          "
-
-SRCREV = "d0fdae3af6998efdce4c6ba0c5d650898c9c5b27"
+BBCLASSEXTEND = "native"
 
 SECTION = "base"
 
-S = "${WORKDIR}/git"
+DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c systemd security-manager libcap-native af-binder"
+DEPENDS_class-native = "openssl libxml2 xmlsec1 libzip json-c"
 
-DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c security-manager libcap-native af-binder"
-
-afm_name    = "afm"
-afm_confdir = "${sysconfdir}/${afm_name}"
-afm_datadir = "${datadir}/${afm_name}"
-afb_plugin_dir = "${libdir}/afb"
+EXTRA_OECMAKE_class-native  = "\
+       -DUSE_LIBZIP=1 \
+       -DUSE_SIMULATION=1 \
+       -DUSE_SDK=1 \
+       -Dafm_name=${afm_name} \
+       -Dafm_confdir=${afm_confdir} \
+       -Dafm_datadir=${afm_datadir} \
+"
 
 EXTRA_OECMAKE = "\
        -DUSE_LIBZIP=1 \
        -DUSE_SIMULATION=0 \
+       -DUSE_SDK=0 \
        -Dafm_name=${afm_name} \
        -Dafm_confdir=${afm_confdir} \
        -Dafm_datadir=${afm_datadir} \
+       -Dsystemd_units_root=${systemd_units_root} \
        -DUNITDIR_USER=${systemd_user_unitdir} \
        -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
 "
@@ -55,41 +45,77 @@ SYSTEMD_AUTO_ENABLE = "enable"
 FILES_${PN} += "\
        ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/afm-user-daemon.service', '', d)} \
 "
-
-RDEPENDS_${PN}_append_smack = " smack-userspace"
+RDEPENDS_${PN}_append_smack = " smack-userspace bash"
 DEPENDS_append_smack = " smack-userspace-native"
 
-# short hack here
-SRC_URI += " file://Hack-to-allow-the-debugging.patch"
+# short hacks here
+SRC_URI += "\
+       file://Hack-to-allow-the-debugging.patch \
+"
+
+# tools used to install wgt at first boot
+SRC_URI += "\
+       file://afm-install \
+"
 
-do_install_append() {
+do_install_append_class-target() {
+    install -d ${D}${bindir}
+    install -d -m 0775 ${D}${systemd_units_root}/system
+    install -d -m 0775 ${D}${systemd_units_root}/user
+    install -d -m 0775 ${D}${systemd_units_root}/system/default.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/user/default.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/system/sockets.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/user/sockets.target.wants
+    install -d ${D}${afm_datadir}/applications
+    install -d ${D}${afm_datadir}/icons
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        mkdir -p ${D}${sysconfdir}/systemd/system/default.target.wants
         mkdir -p ${D}${sysconfdir}/systemd/user/default.target.wants
         ln -sf ${systemd_user_unitdir}/afm-user-daemon.service ${D}${sysconfdir}/systemd/user/default.target.wants
     fi
+    install -m 0755 ${WORKDIR}/afm-install ${D}${bindir}
+    echo "QT_WAYLAND_SHELL_INTEGRATION=ivi-shell" > ${D}${afm_confdir}/unit.env.d/qt-for-ivi-shell
+}
+
+do_install_append_porter() {
+    echo "LD_PRELOAD=/usr/lib/libEGL.so" > ${D}${afm_confdir}/unit.env.d/preload-libEGL
 }
 
 pkg_postinst_${PN}() {
-    mkdir -p $D${afm_datadir}/applications $D${afm_datadir}/icons
-    setcap cap_mac_override,cap_dac_override=ie $D${bindir}/afm-system-daemon
-    setcap cap_mac_override,cap_mac_admin,cap_setgid=ie $D${bindir}/afm-user-daemon
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        for SYS in "system" "user";do
+           for DEST in "sockets.target.wants" "default.target.wants" ".";do
+              chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
+           done
+        done
+    fi
+    for DEST in "applications" "icons" ".";do
+        chown ${afm_name}:${afm_name} $D${afm_datadir}/${DEST};
+    done
+    setcap cap_mac_override,cap_dac_override=ep $D${bindir}/afm-system-daemon
 }
 
 pkg_postinst_${PN}_smack() {
-    mkdir -p $D${afm_datadir}/applications $D${afm_datadir}/icons
-    chown ${afm_name}:${afm_name} $D${afm_datadir} $D${afm_datadir}/applications $D${afm_datadir}/icons
-    chsmack -a 'System::Shared' -t $D${afm_datadir} $D${afm_datadir}/applications $D${afm_datadir}/icons
-    setcap cap_mac_override,cap_dac_override=ie $D${bindir}/afm-system-daemon
-    setcap cap_mac_override,cap_mac_admin,cap_setgid=ie $D${bindir}/afm-user-daemon
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        for SYS in "system" "user";do
+           for DEST in "sockets.target.wants" "default.target.wants" ".";do
+              chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
+              chsmack -a 'System::Shared' -t $D${systemd_units_root}/${SYS}/${DEST};
+           done
+        done
+    fi
+    for DEST in "applications" "icons" ".";do
+        chown ${afm_name}:${afm_name} $D${afm_datadir}/${DEST};
+        chsmack -a 'System::Shared' -t $D${afm_datadir}/${DEST};
+    done
+    setcap cap_mac_override,cap_dac_override=ep $D${bindir}/afm-system-daemon
 }
+FILES_${PN} += " ${systemd_units_root} "
 
-PACKAGES =+ "${PN}-afbplugin ${PN}-afbplugin-dbg"
-FILES_${PN}-afbplugin = " ${afb_plugin_dir}/afm-main-plugin.so "
-FILES_${PN}-afbplugin-dbg = " ${afb_plugin_dir}/.debug/afm-main-plugin.so "
+PACKAGES =+ "${PN}-binding ${PN}-binding-dbg"
+FILES_${PN}-binding = " ${afb_binding_dir}/afm-main-binding.so "
+FILES_${PN}-binding-dbg = " ${afb_binding_dir}/.debug/afm-main-binding.so "
 
 PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
 FILES_${PN}-tools = "${bindir}/wgtpkg-*"
 FILES_${PN}-tools-dbg = "${bindir}/.debug/wgtpkg-*"
-
-BBCLASSEXTEND = "native nativesdk"
-