Fix the error of homescreen for QEMU x86-64
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / af-main_1.0.bb
index c7b8ba4..6a1d36a 100644 (file)
@@ -82,6 +82,10 @@ do_install_append() {
     install -m 0755 ${WORKDIR}/afm-install ${D}${bindir}
 }
 
+do_install_append_qemux86-64() {
+    sed -i -e '/LD_PRELOAD=\/usr\/lib\/libEGL.so/d' ${D}${systemd_user_unitdir}/afm-user-daemon.service
+}
+
 do_install_append_smack () {
     install -d ${D}/${sysconfdir}/smack/accesses.d
     cat > ${D}/${sysconfdir}/smack/accesses.d/default-access-domains-no-user <<EOF