Fix: wrong config.xml used to build widget
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-main / af-main_1.0.bb
index 5cc5740..52a8fe2 100644 (file)
@@ -11,9 +11,11 @@ BBCLASSEXTEND = "native"
 
 SECTION = "base"
 
-DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c systemd security-manager libcap-native af-binder"
+DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c systemd security-manager af-binder"
 DEPENDS_class-native = "openssl libxml2 xmlsec1 libzip json-c"
 
+PACKAGE_WRITE_DEPS_append_smack = " smack-userspace-native libcap-native"
+
 EXTRA_OECMAKE_class-native  = "\
        -DUSE_LIBZIP=1 \
        -DUSE_SIMULATION=1 \
@@ -35,6 +37,8 @@ EXTRA_OECMAKE = "\
        -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
 "
 
+EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=1"
+
 USERADD_PACKAGES = "${PN}"
 USERADD_PARAM_${PN} = "-g ${afm_name} -d ${afm_datadir} -r ${afm_name}"
 GROUPADD_PARAM_${PN} = "-r ${afm_name}"
@@ -45,7 +49,7 @@ SYSTEMD_AUTO_ENABLE = "enable"
 FILES_${PN} += "\
        ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/afm-user-daemon.service', '', d)} \
 "
-RDEPENDS_${PN}_append_smack = " smack-userspace"
+RDEPENDS_${PN}_append_smack = " smack-userspace bash"
 DEPENDS_append_smack = " smack-userspace-native"
 
 # short hacks here
@@ -64,6 +68,8 @@ do_install_append_class-target() {
     install -d -m 0775 ${D}${systemd_units_root}/user
     install -d -m 0775 ${D}${systemd_units_root}/system/default.target.wants
     install -d -m 0775 ${D}${systemd_units_root}/user/default.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/system/sockets.target.wants
+    install -d -m 0775 ${D}${systemd_units_root}/user/sockets.target.wants
     install -d ${D}${afm_datadir}/applications
     install -d ${D}${afm_datadir}/icons
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
@@ -82,7 +88,7 @@ do_install_append_porter() {
 pkg_postinst_${PN}() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         for SYS in "system" "user";do
-           for DEST in "default.target.wants" ".";do
+           for DEST in "sockets.target.wants" "default.target.wants" ".";do
               chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
            done
         done
@@ -96,7 +102,7 @@ pkg_postinst_${PN}() {
 pkg_postinst_${PN}_smack() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         for SYS in "system" "user";do
-           for DEST in "default.target.wants" ".";do
+           for DEST in "sockets.target.wants" "default.target.wants" ".";do
               chgrp ${afm_name} $D${systemd_units_root}/${SYS}/${DEST};
               chsmack -a 'System::Shared' -t $D${systemd_units_root}/${SYS}/${DEST};
            done