af-binder: Fix callsync hanging
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_git.bb
index f5309f0..cf20e25 100644 (file)
@@ -11,7 +11,7 @@ EXTRA_OECMAKE_append_class-target = "\
 EXTRA_OECMAKE_append_agl-devel = " \
        -DAGL_DEVEL=ON \
        -DINCLUDE_MONITORING=ON \
-       -DINCLUDE_SUPERVISOR=ON -DAFS_SURPERVISION_SOCKET=/run/platform/supervisor \
+       -DINCLUDE_SUPERVISOR=ON -DAFS_SUPERVISION_SOCKET=/run/platform/supervisor \
 "
 
 pkg_postinst_${PN}() {
@@ -21,7 +21,7 @@ pkg_postinst_${PN}() {
 do_install_append_agl-devel_class-target() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
-        ln -s ../afs-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afs-supervisor.service
+        ln -s ../afm-api-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-api-supervisor.service
     fi
 }