af-binder: workaround dlopen issue
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index c3c13cd..f5b6fec 100644 (file)
@@ -9,17 +9,22 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=dab"
 SRC_URI_files = ""
 SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
           "
 
-SRCREV = "b192d4cc46d8bda166116432ee28042e95750052"
+SRCREV = "c4c474c056cd070706d5a3b0af7845c9493bfdaf"
+PV = "dab+git${SRCPV}"
+
 S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig
 
+EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=1"
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+
 pkg_postinst_${PN}() {
        mkdir -p "$D${libdir}/afb"
 }