Activates threading and hook features
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index 3e4a8c6..cf5b465 100644 (file)
@@ -1,6 +1,6 @@
 SUMMARY = "HTTP REST interface to automotive backends for HTML5 UI support"
 DESCRIPTION = "Automotive-Framework-Binder Daemon provides a HTTP REST \
-interface to various automotive-oriented bindings (sound, radio...), \
+interface to various automotive-oriented bindings, \
 allowing HTML5 UIs to send platform-specific requests in a secure way."
 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder"
 
@@ -8,21 +8,24 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 DEPENDS = "file json-c libmicrohttpd systemd util-linux"
-DEPENDS += "alsa-lib glib-2.0 gssdp gupnp gupnp-av pulseaudio"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=1.0"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
 SRC_URI_files = ""
 SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
           "
 
-SRCREV = "7059e59cddc1c81321639875636e88895bc14309"
+SRCREV = "2db7c92c0b4f5840884481fa4c95facbdea63bb6"
 S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig
 
 FILES_${PN} += "${datadir}"
 
+pkg_postinst_${PN}() {
+       mkdir -p "$D${libdir}/afb"
+}
+
 #############################################
 # setup meta package
 #############################################
@@ -71,3 +74,5 @@ FILES_libafbwsc-dbg = "\
 "
 RDEPENDS_libafbwsc-dbg += "${PN}-dbg libafbwsc-dev"
 
+RDEPENDS_${PN}-dev += "libafbwsc-dev"
+