Upgrade framework and binder
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index 99ea243..ceeb04a 100644 (file)
@@ -1,14 +1,13 @@
 SUMMARY = "HTTP REST interface to automotive backends for HTML5 UI support"
 DESCRIPTION = "Automotive-Framework-Binder Daemon provides a HTTP REST \
-interface to various automotive-oriented bindings (sound, radio...), \
+interface to various automotive-oriented bindings, \
 allowing HTML5 UIs to send platform-specific requests in a secure way."
 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-DEPENDS = "file json-c libmicrohttpd systemd util-linux"
-DEPENDS += "alsa-lib glib-2.0 gssdp gupnp gupnp-av pulseaudio"
+DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
 SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
 SRC_URI_files = ""
@@ -16,23 +15,35 @@ SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
           "
 
-SRCREV = "bca90021828565bddb8624e8f6370bf4959cbfbf"
+SRCREV = "b2114e0f626ed42a5d6154c681486b4edb19fbbf"
+PV = "master+git${SRCPV}"
+
 S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig
 
-FILES_${PN} += "${datadir}"
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
 
 pkg_postinst_${PN}() {
        mkdir -p "$D${libdir}/afb"
 }
 
 #############################################
-# setup meta package
+# setup package
 #############################################
-PACKAGES += "${PN}-meta"
+PACKAGES += "${PN}-tools ${PN}-meta"
+
+FILES_${PN} += "${datadir}"
+
 ALLOW_EMPTY_${PN}-meta = "1"
 
+FILES_${PN}-tools = "\
+       ${bindir}/afb-client-demo \
+       ${bindir}/afb-genskel \
+"
+
+RDEPENDS_${PN}-dev += "libafbwsc-dev"
+
 #############################################
 # setup sample binding packages
 #############################################
@@ -65,7 +76,6 @@ FILES_libafbwsc = "\
 FILES_libafbwsc-dev = "\
        ${includedir}/afb/afb-wsj1.h \
        ${includedir}/afb/afb-ws-client.h \
-       ${bindir}/afb-client-demo \
        ${libdir}/libafbwsc.so \
        ${libdir}/pkgconfig/libafbwsc.pc \
 "
@@ -75,3 +85,4 @@ FILES_libafbwsc-dbg = "\
 "
 RDEPENDS_libafbwsc-dbg += "${PN}-dbg libafbwsc-dev"
 
+