af-binder: changes the packaging
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index 4fcff66..cc475bd 100644 (file)
@@ -1,50 +1,61 @@
 SUMMARY = "HTTP REST interface to automotive backends for HTML5 UI support"
 DESCRIPTION = "Automotive-Framework-Binder Daemon provides a HTTP REST \
-interface to various automotive-oriented plugins (sound, radio...), \
+interface to various automotive-oriented bindings, \
 allowing HTML5 UIs to send platform-specific requests in a secure way."
 HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder"
 
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
-DEPENDS = "file json-c libmicrohttpd systemd util-linux"
-DEPENDS += "alsa-lib glib-2.0 gssdp gupnp gupnp-av pulseaudio"
+DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=1.0"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
 SRC_URI_files = ""
 SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
           "
 
-SRCREV = "897aa6a130eab1eb716fcc13e650fb5833a7ce32"
+SRCREV = "8abd9262e343aec71e07388bdf829d4f76d6529e"
 S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig
 
-FILES_${PN} += "${datadir}"
+pkg_postinst_${PN}() {
+       mkdir -p "$D${libdir}/afb"
+}
 
 #############################################
-# setup meta package
+# setup package
 #############################################
-PACKAGES += "${PN}-meta"
+PACKAGES += "${PN}-tools ${PN}-meta"
+
+FILES_${PN} += "${datadir}"
+
 ALLOW_EMPTY_${PN}-meta = "1"
 
+FILES_${PN}-tools = "\
+       ${bindir}/afb-client-demo \
+       ${bindir}/afb-genskel \
+"
+
+RDEPENDS_${PN}-dev += "${PN}-tools libafbwsc-dev"
+
 #############################################
-# setup sample plugin packages
+# setup sample binding packages
 #############################################
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
+PACKAGES_DYNAMIC = "${PN}-binding-*"
 
 python populate_packages_prepend () {
     afb_libdir = d.expand('${libdir}/afb')
-    postinst = d.getVar('plugin_postinst', True)
+    postinst = d.getVar('binding_postinst', True)
     pkgs = []
     pkgs_dbg = []
 
-    pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-plugin-%s'), 'AFB plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
-    pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-plugin-%s'), 'AFB plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
+    pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
+    pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
 
-    pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*)-api\.so$', d.expand('${PN}-plugin-%s-dbg'), 'AFB plugin for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
-    pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*(?!-api))\.so$', d.expand('${PN}-plugin-%s-dbg'), 'AFB plugin for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
+    pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*)-api\.so$', d.expand('${PN}-binding-%s-dbg'), 'AFB binding for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
+    pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*(?!-api))\.so$', d.expand('${PN}-binding-%s-dbg'), 'AFB binding for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
 
     metapkg = d.getVar('PN', True) + '-meta'
     d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
@@ -61,7 +72,6 @@ FILES_libafbwsc = "\
 FILES_libafbwsc-dev = "\
        ${includedir}/afb/afb-wsj1.h \
        ${includedir}/afb/afb-ws-client.h \
-       ${bindir}/afb-client-demo \
        ${libdir}/libafbwsc.so \
        ${libdir}/pkgconfig/libafbwsc.pc \
 "
@@ -71,3 +81,4 @@ FILES_libafbwsc-dbg = "\
 "
 RDEPENDS_libafbwsc-dbg += "${PN}-dbg libafbwsc-dev"
 
+