af-binder: Bug fixes and improvements
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index cc475bd..cc078fa 100644 (file)
@@ -9,17 +9,21 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI_files = ""
 SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
           "
 
-SRCREV = "8abd9262e343aec71e07388bdf829d4f76d6529e"
+SRCREV = "b6a483aab99a4bf32d7c04b159de7fcb96a54416"
+PV = "master+git${SRCPV}"
+
 S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig
 
+EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=ON -DINCLUDE_MONITORING=ON"
+
 pkg_postinst_${PN}() {
        mkdir -p "$D${libdir}/afb"
 }
@@ -31,6 +35,8 @@ PACKAGES += "${PN}-tools ${PN}-meta"
 
 FILES_${PN} += "${datadir}"
 
+FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring"
+
 ALLOW_EMPTY_${PN}-meta = "1"
 
 FILES_${PN}-tools = "\
@@ -38,7 +44,7 @@ FILES_${PN}-tools = "\
        ${bindir}/afb-genskel \
 "
 
-RDEPENDS_${PN}-dev += "${PN}-tools libafbwsc-dev"
+RDEPENDS_${PN}-dev += "libafbwsc-dev"
 
 #############################################
 # setup sample binding packages