Upgrade framework and binder
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index ab4a476..c0e2a12 100644 (file)
@@ -9,17 +9,21 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=dab"
 SRC_URI_files = ""
 SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
           "
 
-SRCREV = "8abd9262e343aec71e07388bdf829d4f76d6529e"
+SRCREV = "4e72c3a2a4e550f99430d1f37a8ef693d2daa8c3"
+PV = "dab+git${SRCPV}"
+
 S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig
 
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+
 pkg_postinst_${PN}() {
        mkdir -p "$D${libdir}/afb"
 }