af-binder: Upgrade
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index 4fcff66..91f26b8 100644 (file)
@@ -1,50 +1,69 @@
-SUMMARY = "HTTP REST interface to automotive backends for HTML5 UI support"
-DESCRIPTION = "Automotive-Framework-Binder Daemon provides a HTTP REST \
-interface to various automotive-oriented plugins (sound, radio...), \
-allowing HTML5 UIs to send platform-specific requests in a secure way."
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder"
+require af-binder_${PV}.inc
 
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-DEPENDS = "file json-c libmicrohttpd systemd util-linux"
-DEPENDS += "alsa-lib glib-2.0 gssdp gupnp gupnp-av pulseaudio"
+inherit cmake pkgconfig
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=1.0"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
-           ${SRC_URI_files} \
-          "
+EXTRA_OECMAKE_append_class-target = "\
+       -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
+"
 
-SRCREV = "897aa6a130eab1eb716fcc13e650fb5833a7ce32"
-S = "${WORKDIR}/git"
+EXTRA_OECMAKE_append_agl-devel = " \
+       -DAGL_DEVEL=ON \
+       -DINCLUDE_MONITORING=ON \
+       -DINCLUDE_SUPERVISOR=ON -DAFS_SURPERVISION_SOCKET=/run/platform/supervisor \
+"
 
-inherit cmake pkgconfig
+pkg_postinst_${PN}() {
+       mkdir -p "$D${libdir}/afb"
+}
 
-FILES_${PN} += "${datadir}"
+do_install_append_agl-devel_class-target() {
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
+        ln -s ../afs-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afs-supervisor.service
+    fi
+}
 
 #############################################
-# setup meta package
+# setup package
 #############################################
-PACKAGES += "${PN}-meta"
+PACKAGES =+ "${PN}-tools ${PN}-devtools ${PN}-meta"
+
+FILES_${PN} += "${datadir}"
+
+FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
+
 ALLOW_EMPTY_${PN}-meta = "1"
 
+FILES_${PN}-tools = "\
+       ${bindir}/afb-client-demo \
+"
+
+FILES_${PN}-devtools = "\
+       ${bindir}/afb-exprefs \
+       ${bindir}/afb-json2c \
+       ${bindir}/afb-genskel \
+"
+
+RDEPENDS_${PN}-dev += "libafbwsc-dev"
+
 #############################################
-# setup sample plugin packages
+# setup sample binding packages
 #############################################
-PACKAGES_DYNAMIC = "${PN}-plugin-*"
+PACKAGES_DYNAMIC = "${PN}-binding-*"
 
 python populate_packages_prepend () {
     afb_libdir = d.expand('${libdir}/afb')
-    postinst = d.getVar('plugin_postinst', True)
+    postinst = d.getVar('binding_postinst', True)
     pkgs = []
     pkgs_dbg = []
 
-    pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-plugin-%s'), 'AFB plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
-    pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-plugin-%s'), 'AFB plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
+    pkgs += do_split_packages(d, afb_libdir, '(.*)-api\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
+    pkgs += do_split_packages(d, afb_libdir, '(.*(?!-api))\.so$', d.expand('${PN}-binding-%s'), 'AFB binding for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
 
-    pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*)-api\.so$', d.expand('${PN}-plugin-%s-dbg'), 'AFB plugin for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
-    pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*(?!-api))\.so$', d.expand('${PN}-plugin-%s-dbg'), 'AFB plugin for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
+    pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*)-api\.so$', d.expand('${PN}-binding-%s-dbg'), 'AFB binding for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
+    pkgs_dbg += do_split_packages(d, oe.path.join(afb_libdir, ".debug"), '(.*(?!-api))\.so$', d.expand('${PN}-binding-%s-dbg'), 'AFB binding for %s, debug info', postinst=postinst, extra_depends=d.expand('${PN}'))
 
     metapkg = d.getVar('PN', True) + '-meta'
     d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
@@ -61,7 +80,6 @@ FILES_libafbwsc = "\
 FILES_libafbwsc-dev = "\
        ${includedir}/afb/afb-wsj1.h \
        ${includedir}/afb/afb-ws-client.h \
-       ${bindir}/afb-client-demo \
        ${libdir}/libafbwsc.so \
        ${libdir}/pkgconfig/libafbwsc.pc \
 "
@@ -71,3 +89,4 @@ FILES_libafbwsc-dbg = "\
 "
 RDEPENDS_libafbwsc-dbg += "${PN}-dbg libafbwsc-dev"
 
+