Application Framework: Fix bugs
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index 0c9a78d..91f26b8 100644 (file)
@@ -1,44 +1,48 @@
-SUMMARY = "HTTP REST interface to automotive backends for HTML5 UI support"
-DESCRIPTION = "Automotive-Framework-Binder Daemon provides a HTTP REST \
-interface to various automotive-oriented bindings, \
-allowing HTML5 UIs to send platform-specific requests in a secure way."
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+require af-binder_${PV}.inc
 
 DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
-           ${SRC_URI_files} \
-          "
-
-SRCREV = "305d98f7b6db1a3207cc877bd2cda819e3b90656"
-PV = "master+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
 inherit cmake pkgconfig
 
-CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+EXTRA_OECMAKE_append_class-target = "\
+       -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
+"
+
+EXTRA_OECMAKE_append_agl-devel = " \
+       -DAGL_DEVEL=ON \
+       -DINCLUDE_MONITORING=ON \
+       -DINCLUDE_SUPERVISOR=ON -DAFS_SURPERVISION_SOCKET=/run/platform/supervisor \
+"
 
 pkg_postinst_${PN}() {
        mkdir -p "$D${libdir}/afb"
 }
 
+do_install_append_agl-devel_class-target() {
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
+        ln -s ../afs-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afs-supervisor.service
+    fi
+}
+
 #############################################
 # setup package
 #############################################
-PACKAGES += "${PN}-tools ${PN}-meta"
+PACKAGES =+ "${PN}-tools ${PN}-devtools ${PN}-meta"
 
 FILES_${PN} += "${datadir}"
 
+FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
+
 ALLOW_EMPTY_${PN}-meta = "1"
 
 FILES_${PN}-tools = "\
        ${bindir}/afb-client-demo \
+"
+
+FILES_${PN}-devtools = "\
+       ${bindir}/afb-exprefs \
+       ${bindir}/afb-json2c \
        ${bindir}/afb-genskel \
 "