af-binder-devtools: Align to use app-framework-binder repo
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index 0fc3a67..1850e2b 100644 (file)
@@ -1,25 +1,7 @@
-SUMMARY = "HTTP REST interface to automotive backends for HTML5 UI support"
-DESCRIPTION = "Automotive-Framework-Binder Daemon provides a HTTP REST \
-interface to various automotive-oriented bindings, \
-allowing HTML5 UIs to send platform-specific requests in a secure way."
-HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+require af-binder_${PV}.inc
 
 DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
-SRC_URI_files = ""
-SRC_URI = "${SRC_URI_git} \
-           ${SRC_URI_files} \
-          "
-
-SRCREV = "913e41d02977ee045490fbdcc94979c122c6a981"
-PV = "master+git${SRCPV}"
-
-S = "${WORKDIR}/git"
-
 inherit cmake pkgconfig
 
 EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=ON -DINCLUDE_MONITORING=ON"
@@ -31,7 +13,7 @@ pkg_postinst_${PN}() {
 #############################################
 # setup package
 #############################################
-PACKAGES += "${PN}-tools ${PN}-meta"
+PACKAGES =+ "${PN}-tools ${PN}-devtools ${PN}-meta"
 
 FILES_${PN} += "${datadir}"
 
@@ -41,6 +23,11 @@ ALLOW_EMPTY_${PN}-meta = "1"
 
 FILES_${PN}-tools = "\
        ${bindir}/afb-client-demo \
+"
+
+FILES_${PN}-devtools = "\
+       ${bindir}/afb-exprefs \
+       ${bindir}/afb-json2c \
        ${bindir}/afb-genskel \
 "