af-binder: bug fix and feature improvements
[AGL/meta-agl.git] / meta-app-framework / recipes-core / af-binder / af-binder_1.0.bb
index cc475bd..05a7c76 100644 (file)
@@ -9,17 +9,22 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
 
-SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=master"
+SRC_URI_git = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=dab"
 SRC_URI_files = ""
 SRC_URI = "${SRC_URI_git} \
            ${SRC_URI_files} \
           "
 
-SRCREV = "8abd9262e343aec71e07388bdf829d4f76d6529e"
+SRCREV = "2e4df370fed59a25d0bc157ccfb4642fb26d223f"
+PV = "dab+git${SRCPV}"
+
 S = "${WORKDIR}/git"
 
 inherit cmake pkgconfig
 
+EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=1"
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+
 pkg_postinst_${PN}() {
        mkdir -p "$D${libdir}/afb"
 }
@@ -38,7 +43,7 @@ FILES_${PN}-tools = "\
        ${bindir}/afb-genskel \
 "
 
-RDEPENDS_${PN}-dev += "${PN}-tools libafbwsc-dev"
+RDEPENDS_${PN}-dev += "libafbwsc-dev"
 
 #############################################
 # setup sample binding packages