base-files for the framework
[AGL/meta-agl.git] / meta-app-framework / recipes-config / agl-users / agl-users_0.1.bb
index 0f61248..832c51c 100644 (file)
@@ -10,10 +10,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
 
 SRC_URI = ""
 
-
-RDEPENDS_${PN}_append_smack = " smack-userspace"
-DEPENDS_append_smack = " smack-userspace-native"
-
 ALLOW_EMPTY_${PN} = "1"
 
 USERADD_PACKAGES = "${PN}"
@@ -23,43 +19,3 @@ USERADD_PARAM_${PN} = "\
   -g users -d /home/agl-passenger -m -K PASS_MAX_DAYS=-1 agl-passenger \
 "
 
-
-do_configure() {
-    :
-}
-
-do_compile() {
-    :
-}
-
-do_install() {
-    :
-}
-
-
-pkg_postinst_${PN}() {
-    #!/bin/sh -e
-
-    # avoid to run on host
-    [ x"$D" != "x" ] && exit 1
-
-    # Drops password
-    passwd -d agl-driver
-    passwd -d agl-passenger
-}
-           
-pkg_postinst_${PN}_smack() {
-    #!/bin/sh -e
-
-    # avoid to run on host
-    [ x"$D" != "x" ] && exit 1
-
-    # Actions to carry out on the device go here
-    for x in /etc/skel /home/*
-    do
-        chsmack -a User::Home $x
-    done
-    passwd -d agl-driver
-    passwd -d agl-passenger
-}
-