meta-agl: split wireplumber to run in multiple instances
[AGL/meta-agl.git] / meta-app-framework / classes / aglwgt.bbclass
index 4dd3fec..f42c282 100644 (file)
@@ -9,16 +9,16 @@
 #
 
 # 'wgtpkg-pack' in af-main-native is required.
-DEPENDS_append = " af-main-native"
+DEPENDS:append = " af-main-native"
 
 # for bindings af-binder is required.
-DEPENDS_append = " af-binder"
+DEPENDS:append = " af-binder"
 
 # for bindings that use the cmake-apps-module
-DEPENDS_append = " cmake-apps-module-native"
+DEPENDS:append = " cmake-apps-module-native"
 
 # for hal bindings genskel is required.
-DEPENDS_append = " af-binder-devtools-native"
+DEPENDS:append = " af-binder-devtools-native"
 
 # Re-enable strip for qmake based projects (default value is "echo")
 OE_QMAKE_STRIP = "${STRIP}"
@@ -41,18 +41,14 @@ AGLWGT_CMAKE_CONFIGURE_ARGS ?= "-DCMAKE_TOOLCHAIN_FILE=${WORKDIR}/toolchain.cmak
 # building/packaging of the test widget for other widgets.
 AGLWGT_HAVE_TESTS ?= "0"
 
-# Warning on missing test/debug/coverage packages disabled by default
-# for now to reduce build output clutter.
-AGLWGT_PACKAGE_WARN ?= "0"
-
 # Whether the widget should be auto-installed on first boot
 AGLWGT_AUTOINSTALL ?= "1"
 
 # Signature keys
 # These are default keys for development purposes !
 # Change it for production.
-WGTPKG_AUTOSIGN_0_agl-sign-wgts ??= "${WORKDIR}/recipe-sysroot-native/usr/share/afm/keys/developer.key.pem:${WORKDIR}/recipe-sysroot-native/usr/share/afm/certs/developer.cert.pem"
-WGTPKG_AUTOSIGN_1_agl-sign-wgts ??= "${WORKDIR}/recipe-sysroot-native/usr/share/afm/keys/platform.key.pem:${WORKDIR}/recipe-sysroot-native/usr/share/afm/certs/platform.cert.pem"
+WGTPKG_AUTOSIGN_0:agl-sign-wgts ??= "${WORKDIR}/recipe-sysroot-native/usr/share/afm/keys/developer.key.pem:${WORKDIR}/recipe-sysroot-native/usr/share/afm/certs/developer.cert.pem"
+WGTPKG_AUTOSIGN_1:agl-sign-wgts ??= "${WORKDIR}/recipe-sysroot-native/usr/share/afm/keys/platform.key.pem:${WORKDIR}/recipe-sysroot-native/usr/share/afm/certs/platform.cert.pem"
 
 export WGTPKG_AUTOSIGN_0
 export WGTPKG_AUTOSIGN_1
@@ -75,7 +71,11 @@ python aglwgt_cmake_configure () {
         d.appendVarFlag("AGLWGT_EXTRA_BUILD_ARGS", "vardeps", " AGLWGT_CMAKE_CONFIGURE_ARGS")
 }
 
-do_configure[noexec] = "1"
+# Placeholder to keep things like externalsrc that prefunc or append
+# do_configure working as expected.
+aglwgt_do_configure() {
+    true
+}
 
 aglwgt_do_compile() {
     bldcmd=${S}/autobuild/agl/autobuild
@@ -89,22 +89,17 @@ aglwgt_do_compile() {
         cd ${B}
     fi
 
-    if ! $bldcmd package BUILD_DIR=${B}/build-release ${AGLWGT_EXTRA_BUILD_ARGS}; then
-        bbwarn "Target: package failed"
-    fi
-
-    if ! $bldcmd package-debug BUILD_DIR_DEBUG=${B}/build-debug ${AGLWGT_EXTRA_BUILD_ARGS}; then
-        bbwarn "Target: package-debug failed"
-    fi
+    $bldcmd package BUILD_DIR=${B}/build-release ${AGLWGT_EXTRA_BUILD_ARGS}
+    $bldcmd package-debug BUILD_DIR_DEBUG=${B}/build-debug ${AGLWGT_EXTRA_BUILD_ARGS}
 
     if echo ${BPN} | grep -q '^agl-service-' || [ "${AGLWGT_HAVE_TESTS}" = "1" ]; then
-        if ! $bldcmd package-test BUILD_DIR_TEST=${B}/build-test ${AGLWGT_EXTRA_BUILD_ARGS}; then
-            bbwarn "Target: package-test failed"
+        # Only try building the test widget if there's source for it, to avoid spurious errors
+        if [ -f ${S}/test/CMakeLists.txt ]; then
+            $bldcmd package-test BUILD_DIR_TEST=${B}/build-test ${AGLWGT_EXTRA_BUILD_ARGS}
         fi
 
-        if ! $bldcmd package-coverage BUILD_DIR_COVERAGE=${B}/build-coverage ${AGLWGT_EXTRA_BUILD_ARGS}; then
-            bbwarn "Target: package-coverage failed"
-        fi
+        # The coverage widget should always build
+        $bldcmd package-coverage BUILD_DIR_COVERAGE=${B}/build-coverage ${AGLWGT_EXTRA_BUILD_ARGS}
     fi
 }
 
@@ -119,22 +114,33 @@ aglwgt_do_install() {
         DEST=manualinstall
     fi
 
-    if [ "$(find ${B}/build-release -name '*.wgt' -maxdepth 1)" ]; then
+    wgt="$(find ${B}/build-release -maxdepth 1 -name '*.wgt'| head -n 1)"
+    if [ -n "$wgt" ]; then
         install -d ${D}/usr/AGL/apps/$DEST
-        install -m 0644 ${B}/build-release/*.wgt ${D}/usr/AGL/apps/$DEST/
+        install -m 0644 $wgt ${D}/usr/AGL/apps/$DEST/
     else
         bbfatal "no package found in widget directory"
     fi
 
-    for t in test debug coverage; do
-        if [ "$(find ${B}/build-${t} -name *-${t}.wgt -maxdepth 1)" ]; then
+    for t in debug coverage test; do
+        if [ "$(find ${B}/build-${t} -maxdepth 1 -name *-${t}.wgt)" ]; then
             install -d ${D}/usr/AGL/apps/${t}
             install -m 0644 ${B}/build-${t}/*-${t}.wgt ${D}/usr/AGL/apps/${t}/
-        elif [ "${AGLWGT_PACKAGE_WARN}" = "1" ]; then
-            if [ "$t" != "test" -a "$t" != "coverage" ]; then
-                bbwarn "no package found in ${t} widget directory"
-            elif echo ${BPN} | grep -q '^agl-service-' || [ "${AGLWGT_HAVE_TESTS}" = "1" ]; then
-                bbwarn "no package found in ${t} widget directory"
+        elif [ "$t" = "debug" ]; then
+            # HTML5 widgets complicate things here, need to detect them and
+            # not error out in that case.  ATM this requires looking in the
+            # config.xml of the release widget.
+            rm -rf ${B}/tmp
+            unzip $wgt config.xml -d ${B}/tmp
+            if [ -f ${B}/tmp/config.xml -a \
+                 ! cat ${B}/tmp/config.xml | \
+                     grep -q '^[[:space:]]*<content[[:space:]]\+src="[^\"]*"[[:space:]]\+type="text/html"' ]; then
+                bbfatal "no package found in ${t} widget directory"
+            fi
+            rm -rf ${B}/tmp
+        elif echo ${BPN} | grep -q '^agl-service-' || [ "${AGLWGT_HAVE_TESTS}" = "1" ]; then
+            if [ "$t" = "coverage" -o -f ${S}/test/CMakeLists.txt ]; then
+                bbfatal "no package found in ${t} widget directory"
             fi
         fi
     done
@@ -163,17 +169,17 @@ EOF
 
 PACKAGES += "${PN}-test ${PN}-debug ${PN}-coverage"
 
-FILES_${PN} += " \
+FILES:${PN} += " \
     /usr/AGL/apps/release/*.wgt \
     /usr/AGL/apps/autoinstall \
     /usr/AGL/apps/manualinstall \
     ${sysconfdir}/agl-postinsts/${POST_INSTALL_SCRIPT} \
 "
-FILES_${PN}-test = "/usr/AGL/apps/test/*.wgt"
-FILES_${PN}-debug = "/usr/AGL/apps/debug/*.wgt"
-FILES_${PN}-coverage = "/usr/AGL/apps/coverage/*.wgt"
+FILES:${PN}-test = "/usr/AGL/apps/test/*.wgt"
+FILES:${PN}-debug = "/usr/AGL/apps/debug/*.wgt"
+FILES:${PN}-coverage = "/usr/AGL/apps/coverage/*.wgt"
 
 # Test widgets need the parent widget and the test framework
-RDEPENDS_${PN}-test = "${PN} afb-test"
+RDEPENDS:${PN}-test = "${PN} afb-test"
 
-EXPORT_FUNCTIONS do_compile do_install
+EXPORT_FUNCTIONS do_configure do_compile do_install