Updates for BSP v5.5.0
[AGL/meta-agl-refhw.git] / meta-agl-refhw-gen3 / recipes-bsp / arm-trusted-firmware / arm-trusted-firmware_%.bbappend
index 962f84e..b02096f 100644 (file)
@@ -1,5 +1,7 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 
+SRC_URI_append_rcar-gen3 = " file://0001-rcar_gen3-plat-Do-not-panic-on-unrecognized-boards.patch"
+
 # Apply the patch AGL applies for all rcar3 in meta-agl-bsp when
 # building the standalone agl-refhw-h3 machine.
 SRC_URI_append_agl-refhw-h3 = " file://0001-Boot-Normal-World-in-EL2.patch"
@@ -26,6 +28,10 @@ EMMC_BOOT_OPTION = "RCAR_SA6_TYPE=1"
 #
 DDR_8G_OPTION = "RCAR_DRAM_LPDDR4_MEMCONF=1 RCAR_DRAM_MEMRANK=2"
 
+# AGL reference hardware numbered 100 or above has 16Gbit/1rank DRAM
+# and please flash the firmware built with the following options.
+DDR_8G_1RANK_OPTION = "RCAR_DRAM_LPDDR4_MEMCONF=1 RCAR_DRAM_MEMRANK=1"
+
 ATFW_OPT_agl-refhw-h3 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
 
 #
@@ -34,6 +40,19 @@ ATFW_OPT_agl-refhw-h3 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_O
 
 # Build options for building as extra firmware when MACHINE=h3ulcb, based on H3[4x2g]
 H3ULCB[agl-refhw-4x2g] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
+H3ULCB[agl-refhw-4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_1RANK_OPTION}"
+
+python __anonymous() {
+    # If building for MACHINE=agl-refhw-h3, the predefined default
+    # extra configurations in the base recipe are not interesting
+    # to us, as there is no compatible hardware.
+    if d.getVar("MACHINE") == "agl-refhw-h3":
+        d.delVarFlag("H3", "2x2g")
+        d.delVarFlag("H3", "4x2g")
+}
+
+# Also build the extra 1rank firmware when MACHINE=agl-refhw-h3
+H3[4x2g-1rank] = "LSI=H3 RCAR_DRAM_SPLIT=1 ${EMMC_BOOT_OPTION} ${DDR_8G_1RANK_OPTION}"
 
 #
 # Need to prepend the compile tasks with a distclean that actually cleans