3rd part of the layer/profile rework [1/2]
[AGL/meta-agl.git] / meta-agl-profile-graphical-qt5 / recipes-platform / packagegroups / packagegroup-agl-appfw-native-qt5.bb
diff --git a/meta-agl-profile-graphical-qt5/recipes-platform/packagegroups/packagegroup-agl-appfw-native-qt5.bb b/meta-agl-profile-graphical-qt5/recipes-platform/packagegroups/packagegroup-agl-appfw-native-qt5.bb
new file mode 100644 (file)
index 0000000..a05d69f
--- /dev/null
@@ -0,0 +1,29 @@
+SUMMARY = "Qt5 for native GUI framework of AGL IVI profile"
+DESCRIPTION = "A set of Qt5 packages which required by Native App Fw Subsystem"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-appfw-native-qt5 \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    qtbase \
+    qtbase-dev \
+    qtbase-plugins \
+    qtbase-staticdev \
+    qtbase-tools \
+    qtdeclarative \
+    qtdeclarative-qmlplugins \
+    qtdeclarative-tools \
+    qtcharts \
+    qtwayland \
+    qtwayland-plugins \
+    qtwayland-tools \
+    qtgraphicaleffects-qmlplugins \
+    qtvirtualkeyboard \
+    "