3rd part of the layer/profile rework [1/2]
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-platform / packagegroups / packagegroup-agl-profile-graphical.bb
diff --git a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb
new file mode 100644 (file)
index 0000000..46187fe
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required for AGL Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-profile-graphical \
+    profile-graphical \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    packagegroup-agl-image-minimal \
+    packagegroup-agl-image-weston \
+    packagegroup-agl-graphical-services \
+"
+
+RDEPENDS_profile-graphical = "${PN}"