meta-agl-profile-graphical: add SMACK labelling for weston
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / weston_8.0.0.bbappend
index 03626ab..bafd6bb 100644 (file)
@@ -6,11 +6,21 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 #    and waltham can take a look and update it.
 SRC_URI_append = "\
     file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
-    file://use-XDG_RUNTIMESHARE_DIR.patch \
     file://0002-ivi-shell-Fix-crash-due-no-transmitter-screen.patch \
     file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
     file://0004-unconditionally-include-mman.h.patch \
-    file://0005-add-memfd-create-option.patch \
+    file://smack-weston \
     "
 
-EXTRA_OEMESON_append = " -Denable-user-start=true -Dmemfd-create=false"
+EXTRA_OEMESON_append = " -Denable-user-start=true"
+
+do_install_append() {
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
+        # Install SMACK rules
+        install -D -m 0644 ${WORKDIR}/smack-weston ${D}${sysconfdir}/smack/accesses.d/weston
+    fi
+}
+
+FILES_${PN} += "\
+    ${sysconfdir}/smack/accesses.d/* \
+"