Cluster demo support updates
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / weston_8.0.%.bbappend
index bafd6bb..bada11c 100644 (file)
@@ -8,12 +8,16 @@ SRC_URI_append = "\
     file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
     file://0002-ivi-shell-Fix-crash-due-no-transmitter-screen.patch \
     file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
-    file://0004-unconditionally-include-mman.h.patch \
+    file://0004-main-change-remoting-initialization-timing.patch \
     file://smack-weston \
     "
 
 EXTRA_OEMESON_append = " -Denable-user-start=true"
 
+# Workaround for incorrect upstream definition
+PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
+PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
+
 do_install_append() {
     if ${@bb.utils.contains('DISTRO_FEATURES', 'smack', 'true', 'false', d)}; then
         # Install SMACK rules