meta-agl-profile-graphical: update weston and weston-init
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / weston-init.bbappend
index 247aeee..c71402f 100644 (file)
@@ -2,17 +2,14 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 inherit agl-graphical
 
-
 WESTONSTART ??= "${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", "/usr/bin/agl-compositor", "/usr/bin/weston",d)} ${WESTONARGS}"
 WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/weston.log", "",d)}"
 
-DROPIN_NAME = "weston-init"
-
 WIFILES = " \
     file://weston.conf.in \
     file://tmpfiles.conf.in \
     file://zz-dri.rules.in \
-    file://zz-input.rules \
+    file://zz-input.rules.in \
     file://zz-tty.rules.in \
 "
 
@@ -23,37 +20,34 @@ WIFILES_append_imx = " \
 SRC_URI_append = " ${WIFILES}"
 
 do_install_append() {
+    # Remove upstream weston.ini to avoid conflict with weston-ini-conf package
+    rm -f ${D}${sysconfdir}/xdg/weston/weston.ini
 
-    # files
-    files=$(echo ${WIFILES} | sed s,file://,,g)
+    # Remove upstream weston udev rules just to be safe
+    rm -f ${D}${sysconfdir}/udev/rules.d/71-weston-drm.rules
 
-    # process ".in" files
+    # Process ".in" files
+    files=$(echo ${WIFILES} | sed s,file://,,g)
     for f in ${files}; do
         g=${f%.in}
         if [ "${f}" != "${g}" ]; then
             sed -e "s,@WESTONUSER@,${WESTONUSER},g" \
                 -e "s,@WESTONGROUP@,${WESTONGROUP},g" \
                 -e "s,@XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g" \
-                -e "s,@WESTONTTY@,${WESTONTTY},g" \
                 -e "s,@WESTONSTART@,${WESTONSTART},g" \
                     ${WORKDIR}/${f} > ${WORKDIR}/${g}
         fi
     done
 
-    # removes any unexpected entry from weston.service
-    for x in Group User ExecStart PAMName; do
-        sed -i "/^ *$x *=/d" ${D}${systemd_system_unitdir}/weston.service
-    done
-
-    # install weston drop-in
-    install -d ${D}${systemd_system_unitdir}/weston.service.d
-    install -m644 ${WORKDIR}/weston.conf ${D}/${systemd_system_unitdir}/weston.service.d/${DROPIN_NAME}.conf
+    # Install weston drop-in
+    install -d ${D}${systemd_system_unitdir}/weston@.service.d
+    install -m644 ${WORKDIR}/weston.conf ${D}/${systemd_system_unitdir}/weston@.service.d/weston-init.conf
 
-    # install tmpfiles drop-in
+    # Install tmpfiles drop-in
     install -d ${D}${libdir}/tmpfiles.d
-    install -m644 ${WORKDIR}/tmpfiles.conf ${D}${libdir}/tmpfiles.d/${DROPIN_NAME}.conf
+    install -m644 ${WORKDIR}/tmpfiles.conf ${D}${libdir}/tmpfiles.d/weston-init.conf
 
-    # install udev rules
+    # Install udev rules
     install -d ${D}${sysconfdir}/udev/rules.d
     for f in ${files}; do
         g=${f%.in}
@@ -65,8 +59,9 @@ do_install_append() {
 }
 
 FILES_${PN} += " \
-    ${libdir}/tmpfiles.d/*.conf \
-    ${systemd_system_unitdir}/weston.service.d/${DROPIN_NAME}.conf \
+    ${libdir}/tmpfiles.d/ \
+    ${systemd_system_unitdir}/weston@.service.d/ \
 "
 
+SYSTEMD_AUTO_ENABLE = "enable"