waltham_%.bbappend: Added bbappend recipe for waltham
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / wayland / agl-compositor_git.bb
index c885654..b7a672c 100644 (file)
@@ -11,11 +11,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
 DEPENDS = "wayland wayland-protocols wayland-native weston"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "fcd71e034d378921e0408a69dedcd8d0f4836401"
+SRCREV = "9bb8ea6f6156502bf1639ce349907b391e9b124d"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
 
+PACKAGECONFIG[policy-deny-all] = "-Dpolicy-default=deny-all,,"
+
 inherit meson pkgconfig python3native
 
-FILES_${PN} = "${bindir}/agl-compositor ${datadir}/${PN}/protocols/agl-shell.xml ${datadir}/${PN}/protocols/agl-shell-desktop.xml"
+FILES_${PN} = " \
+               ${bindir}/agl-compositor \
+               ${bindir}/agl-screenshooter \
+               ${datadir}/${PN}/protocols/agl-shell.xml \
+               ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
+              "