Merge "Move hmi-framework and eg-virt from meta-agl-devel to meta-agl"
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-graphics / libhomescreen / libhomescreen_git.bb
diff --git a/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb b/meta-agl-profile-graphical/recipes-graphics/libhomescreen/libhomescreen_git.bb
new file mode 100644 (file)
index 0000000..1acd7af
--- /dev/null
@@ -0,0 +1,26 @@
+SUMMARY     = "AGL Home Screen Library"
+DESCRIPTION = "libhomescreen"
+HOMEPAGE    = "http://docs.automotivelinux.org"
+LICENSE     = "Apache-2.0"
+SECTION     = "libs"
+
+BBCLASSEXTEND = " nativesdk"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "af-binder json-c"
+
+inherit cmake
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
+          file://org.agl.statusbar.conf \
+         "
+SRCREV = "44290c49e08fe52d6e3ed80720473577131090f4"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+       mkdir -p ${D}${sysconfdir}/dbus-1/session.d
+       install -m 0644 ${WORKDIR}/org.agl.statusbar.conf  ${D}${sysconfdir}/dbus-1/session.d
+}
+
+RDEPENDS_${PN} = "agl-service-homescreen"