Merge "Move hmi-framework and eg-virt from meta-agl-devel to meta-agl"
[AGL/meta-agl.git] / meta-agl-profile-graphical / recipes-apis / agl-service-windowmanager / agl-service-windowmanager_git.bb
diff --git a/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb b/meta-agl-profile-graphical/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bb
new file mode 100644 (file)
index 0000000..9be3550
--- /dev/null
@@ -0,0 +1,33 @@
+SUMMARY     = "Window Manager service binding for applications"
+DESCRIPTION = "Window Manager is the service binding for controlling \
+               rendering rights. Applications request to render itself, \
+               then Window Manager checks the policy and notifies the \
+               layout to the respective applications \
+              "
+HOMEPAGE    = "https://wiki.automotivelinux.org/windowmanager"
+SECTION     = "graphics"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS = "af-binder json-c wayland wayland-ivi-extension"
+
+inherit cmake aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH} \
+           file://weston-ready.conf \
+"
+SRCREV = "b6644e5cffa84e40d62e38f4ee0c14e64e0faf48"
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+    # Install systemd over-ride that adds a dependency on weston-ready
+    # to ensure that the windowmanager and its dependencies start after
+    # weston is actually initialized.
+    install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+    install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+REDEPENDS_${PN} += "weston-ready"