afb-test: add missing jq package to RDEPENDS
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-test / afb-test / afb-test_git.bb
index 7f5a221..ee2ea7a 100644 (file)
@@ -6,20 +6,20 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 SECTION = "apps"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "3c1dab4cb0457a97d71365e58c5ea033c1f0a42c"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/app-afb-test;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "eb4d2471f1609e217b2a3a919eeb7d76ca1c7417"
 
-DEPENDS += "lua"
-RDEPENDS_${PN} += "lua bash"
+DEPENDS += "lua libafb-helpers libappcontroller"
+RDEPENDS_${PN} += "lua bash jq"
 RDEPENDS_${PN}-ptest += "af-binder"
 
-PV = "5.99-FF.RC5.0+git${SRCPV}"
+PV = "${AGLVERSION}"
 S  = "${WORKDIR}/git"
 
 inherit cmake aglwgt pkgconfig ptest
 
 do_install_append() {
-       install -d ${D}${bindir}
-       install -m 775 ${B}/afm-test ${D}${bindir}/afm-test
+       install -d ${D}${bindir}
+       install -m 775 ${S}/afm-test.target.sh ${D}${bindir}/afm-test
 }