profile-core: agl-service-network: add agl-service-network-tools package
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-multimedia / lightmediascanner / lightmediascanner_%.bbappend
index cf248d3..7a1dd1a 100644 (file)
@@ -31,3 +31,13 @@ do_install_append() {
 FILES_${PN} += " \
     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/lightmediascanner.service', '', d)} \
     "
+
+# for DEMO
+EXTRA_OECONF = "--enable-static"
+PACKAGECONFIG[mp4] = "--enable-mp4,--disable-mp4,libmp4v2"
+
+# add support MP3 because of the format of music files for AGL CES/ALS2017 Demo
+PACKAGECONFIG_append = " id3 mp4"
+
+# add required character sets for id3 tag scanning
+RDEPENDS_${PN}_append = " glibc-gconv-utf-16 glibc-gconv-iso8859-1"