Upgrade to thud
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-devtools / run-postinsts / run-postinsts_%.bbappend
index fc327b6..4cc2edf 100644 (file)
@@ -1,5 +1,14 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://ldconfig-wait.conf"
+
 do_configure_append() {
        if ! grep -q StandardOutput= ${WORKDIR}/run-postinsts.service; then
                sed -i '/ExecStart=/iStandardOutput=journal+console' ${WORKDIR}/run-postinsts.service
        fi
 }
+
+do_install_append() {
+       install -d ${D}${sysconfdir}/systemd/system/run-postinsts.service.d
+       install -m 0644 ${WORKDIR}/ldconfig-wait.conf ${D}${sysconfdir}/systemd/system/run-postinsts.service.d
+}