Add nogfx build for h3ulcb
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-core / systemd / systemd_%.bbappend
index 815fed8..8c7da43 100644 (file)
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 SRC_URI += "\
     file://e2fsck.conf \
+    file://canbus-can.network \
     ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','file://wired.network','',d)} \
 "
 
@@ -14,6 +15,9 @@ do_install_append() {
     # Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
     install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
 
+    # Install canbus network script
+    install -m 0644 ${WORKDIR}/canbus-can.network ${D}${base_libdir}/systemd/network/60-canbus-can.network
+
     if ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','systemd','true','false',d)}; then
        # Install DHCP configuration for Ethernet adapters
        install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network