meta-agl-profile-core: recipes-connectivity: bluez: add notification status
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-connectivity / bluez5 / bluez5_%.bbappend
index c5afa87..736f18c 100644 (file)
@@ -1,13 +1,14 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append = " file://bluetooth.conf"
-
-APPLY_v522 = "${@str('no' if '${PV}' != '5.22' else 'yes')}"
-
-SRC_URI_append = "\
-    file://0001_fix_compile_issue_when_using_in_c++.patch;apply=${APPLY_v522} \
+SRC_URI_append = " \
+    file://bluetooth.conf \
+    file://0001-obex-report-notification-status-on-incoming-message.patch \
 "
 
-
 do_install_append() {
     install -m 0644 ${WORKDIR}/bluetooth.conf ${D}${sysconfdir}/dbus-1/system.d/bluetooth.conf
+
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+        mkdir -p ${D}/etc/systemd/user
+        ln -sf ${systemd_user_unitdir}/obex.service ${D}/etc/systemd/user/dbus-org.bluez.obex.service
+    fi
 }