meta-agl-profile-core: update bluez5 for dunfell
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-connectivity / bluez5 / bluez5_%.bbappend
index 36fb315..52ae30b 100644 (file)
@@ -2,7 +2,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
 SRC_URI_append = " \
     file://bluetooth.conf \
     file://tmpdir.conf \
-    file://0001-obex-report-notification-status-on-incoming-message.patch \
+    file://obex.service \
+    file://bluetooth.service \
 "
 
 FILES_${PN} += "${systemd_user_unitdir}/obex.service.d/tmpdir.conf"
@@ -12,8 +13,12 @@ do_install_append() {
 
     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
         mkdir -p ${D}${systemd_user_unitdir}/obex.service.d
+
+        install -m 0644 ${WORKDIR}/obex.service ${D}${systemd_user_unitdir}
         install -m 0644 ${WORKDIR}/tmpdir.conf ${D}${systemd_user_unitdir}/obex.service.d/tmpdir.conf
         mkdir -p ${D}/etc/systemd/user
         ln -sf ${systemd_user_unitdir}/obex.service ${D}/etc/systemd/user/dbus-org.bluez.obex.service
+        mkdir -p ${D}${systemd_system_unitdir}
+        install -m 0644 ${WORKDIR}/bluetooth.service ${D}${systemd_system_unitdir}
     fi
 }