Remove eclipse integration from agl-devel
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-apis / agl-service-navigation / agl-service-navigation_git.bb
index 0c245b3..71a615c 100755 (executable)
@@ -1,17 +1,18 @@
 SUMMARY     = "Navigation Service Binding"
 DESCRIPTION = "AGL Navigation Service API Binding"
-HOMEPAGE    = "https://github.com/AGLExport/agl-service-navigation"
 SECTION     = "apps"
 
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://github.com/AGLExport/agl-service-navigation;protocol=git;branch=master"
-SRCREV  = "1f1ffc92fcc882aa5e885badbc91a3384f5d77b1"
+DEPENDS = "json-c libdbus-c++"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-navigation;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 PV = "0.1+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-DEPENDS = " json-c libdbus-c++ "
-
 inherit cmake aglwgt pkgconfig
+
+RDEPENDS_${PN} += "json-c libdbus-c++"