Enable J1939 support for qemu machines
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-apis / agl-service-can-low-level / agl-service-can-low-level_git.bb
index ca6d48e..83f6c1e 100644 (file)
@@ -6,13 +6,18 @@ SECTION     = "apps"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-can-low-level;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "7c5d80deacad2a1f6943dd0b77449c3f6e20fdfc"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-can-low-level;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
-PV = "5.0+git${SRCPV}"
+PV = "${AGLVERSION}"
 S  = "${WORKDIR}/git"
 
-RDEPENDS_${PN} = "dev-mapping"
+DEPENDS = "libafb-helpers libappcontroller"
 
-inherit cmake aglwgt pkgconfig
+inherit cmake aglwgt pkgconfig ptest
 
+# For now, just enable J1939 on the qemu platforms where we know the
+# linux-yocto kernel is new enough (>= 5.4) and has the support enabled.
+AGLWGT_CMAKE_CONFIGURE_ARGS_append_qemuall = " -DWITH_FEATURE_J1939=ON"
+
+RDEPENDS_${PN} = "virtual/low-can-dev-mapping"