Enable J1939 support for qemu machines
[AGL/meta-agl.git] / meta-agl-profile-core / recipes-apis / agl-service-can-low-level / agl-service-can-low-level_git.bb
index 5eb16b9..83f6c1e 100644 (file)
@@ -12,8 +12,12 @@ SRCREV = "${AGL_APP_REVISION}"
 PV = "${AGLVERSION}"
 S  = "${WORKDIR}/git"
 
-DEPENDS = "libafb-helpers"
-RDEPENDS_${PN} = "dev-mapping"
+DEPENDS = "libafb-helpers libappcontroller"
 
 inherit cmake aglwgt pkgconfig ptest
 
+# For now, just enable J1939 on the qemu platforms where we know the
+# linux-yocto kernel is new enough (>= 5.4) and has the support enabled.
+AGLWGT_CMAKE_CONFIGURE_ARGS_append_qemuall = " -DWITH_FEATURE_J1939=ON"
+
+RDEPENDS_${PN} = "virtual/low-can-dev-mapping"