meta-agl-flutter: rework agl-image-flutter
[AGL/meta-agl-devel.git] / meta-agl-flutter / recipes-platform / images / agl-image-flutter-debug.bb
index 2c24699..c9c1f29 100644 (file)
@@ -1,20 +1,29 @@
-SUMMARY = "Baseline Flutter Image for Development"
+require recipes-platform/images/agl-image-compositor.bb
 
+SUMMARY = "Example Flutter application debug image for development"
 LICENSE = "MIT"
 
-require agl-image-flutter.inc
+CLANGSDK = "1"
 
-IMAGE_INSTALL:append = "\
+# NOTES:
+# - the package-management IMAGE_FEATURE and packagegroup-agl-core-devel
+#   are explicitly added here to cover the usecase of building without
+#   passing agl-devel to aglsetup.sh.  This is explicitly a debug image
+#   where those are are always desired.
+# - Getting the debug version of the application requires changing
+#   the value of FLUTTER_APP_RUNTIME_MODES to include "debug",
+#   which is outside the scope of this image recipe.
+
+IMAGE_FEATURES += "ssh-server-openssh package-management dbg-pkgs"
+
+IMAGE_INSTALL += "\
+    packagegroup-agl-core-devel \
+    \
     weston-ini-conf-landscape \
     \
-    ivi-homescreen-debug \
-    flutter-engine-debug \
+    flutter-auto-verbose-logs \
     \
-    flutter-gallery-debug \
-    flutter-test-secure-storage-debug \
-    flutter-test-texture-egl-debug \
-    flutter-test-video-player-debug \
+    flutter-engine-sdk-dev \
     \
-    flutter-app-igalia-homescreen-debug \
-    flutter-app-pumped-fuel-ped-debug \
-    "
+    flutter-gallery \
+"